Deploymate updated to detect unavailable frameworks

Wednesday, 03 Apr 2013

Press release

Deploymate just got a updated to version 1.1 bringing some new features and bugfixes. The update features support for detecting unavailable linked frameworks, target analysis for minimum safe deployment OS version, support for older Mac OS X operating systems (10.7 Lion) and many other small improvements and bug fixes.

Read full post for more information about the features.

Support for unavailable frameworks

Deploymate will now also determine which frameworks are linked in your project and warn you if you are (strong) linking a framework that doesn't exist in your selected target OS version. This safety check is done to prevent incidental app crashes due to unavailable frameworks and acts as a reminder to weak link appropriate frameworks.

Minimum OS version deployment analysis

Since your project API usage is being analyzed, Deploymate is also aware what is the minimum target deployment OS version you can safely run your application on. This makes it very simple to determine the feasibility of supporting older operating systems by your application. Simply run the analysis with Deploymate and quickly figure this out. This small feature can help with backporting along with API usage analysis which will give the developer an indication of how much work would there be.

Dealing with false-positives, part 1

There has been made a small step towards detecting false positives during the analysis. Deploymate can now detect when class selector is performed on an unavailable API type e.g. [Type class] and will not report this behavior as problematic since it doesn't cause the app to crash. This will help reduce the noise for a tiny bit and it's a step towards more options to deal with false-positives. Please note that this option will just skip that actual method call, it will not (yet) silence any code you might have wrapped inside an (e.g.)if statement.

Lion users rejoice!

The update also brings support for older Macs running Mac OS X 10.7 Lion and starting now, Deploymate runs on 10.7 but still requires Xcode version 4.5 as minimum.


comments powered by Disqus